home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / sys-kernel / linux-headers-2.6.11-r2 / linux-headers-2.6.11-r2.ebuild < prev    next >
Text File  |  2005-10-13  |  2KB  |  40 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11-r2.ebuild,v 1.17 2005/09/29 14:38:02 gustavoz Exp $
  4.  
  5. ETYPE="headers"
  6. H_SUPPORTEDARCH="alpha amd64 arm hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
  7. inherit eutils kernel-2
  8. detect_version
  9.  
  10. PATCHES_V='5'
  11.  
  12. SRC_URI="${KERNEL_URI} mirror://gentoo/linux-2.6.11-m68k-headers.patch.bz2
  13.     http://dev.gentoo.org/~plasmaroo/patches/kernel/gentoo-headers/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2"
  14. KEYWORDS="-* amd64 arm hppa ia64 m68k ppc ppc64 s390 sh ~sparc x86" # Not tested to be fully stable, if things break file bugs to plasmaroo please...
  15.  
  16. DEPEND="ppc? ( gcc64? ( sys-devel/gcc-powerpc64 ) )
  17.         sparc? ( gcc64? ( sys-devel/gcc-sparc64 ) )"
  18.  
  19. UNIPATCH_LIST="${DISTDIR}/gentoo-headers-${PV}-${PATCHES_V}.tar.bz2"
  20.  
  21. src_unpack() {
  22.     kernel-2_src_unpack
  23.  
  24.     # This should always be used but it has a bunch of hunks which
  25.     # apply to include/linux/ which i'm unsure of so only use with
  26.     # m68k for now (dont want to break other arches)
  27.     [[ $(tc-arch) == "m68k" ]] && epatch "${DISTDIR}"/linux-2.6.11-m68k-headers.patch.bz2
  28.  
  29.     # Fixes ... all the mv magic is to keep sed from dumping
  30.     # ugly warnings about how it can't work on a directory.
  31.     cd "${S}"/include
  32.     mv asm-ia64/sn asm-ppc64/iSeries .
  33.     headers___fix asm-ia64/*
  34.     mv sn asm-ia64/
  35.     headers___fix asm-ppc64/*
  36.     mv iSeries asm-ppc64/
  37.     headers___fix asm-ppc64/iSeries/*
  38.     headers___fix linux/{ethtool,jiffies}.h
  39. }
  40.